All Sonnox plug-ins should be fully compatible with macOS 10.13, "High Sierra".

We highly recommend using the most up to date version of your Sonnox plug-ins to fully ensure compatibility. You can download the newest installers for your plug-ins from your mySonnox portal!

Additionally, you may need to ensure that your DAW and other software that you rely on is fully compatible with High Sierra before you upgrade. Any version of Pro Tools earlier than 12.8.3 is not compatible with High Sierra, and we recommend upgrading further to the newest version, 2018.x.