Registered owners of Native and HDX Generation 5 (G5) Oxford EQ, Dynamics, Reverb, TransMod, Inflator, Limiter and SuprEsser licences are now able to add compatibility with Waves SoundGrid.

To upgrade your existing plug-ins, simply:

  1. Purchase and register your plug-in.
  2. Go to mySonnox and enter your details.
  3. Locate the plug-in you wish to add to SoundGrid and tick the option from the upgrade selector.
  4. Click the Checkout button at the top of the page.

Upgrading will cost £15 GBP per plug-in.

Why can't I upgrade to SoundGrid?

  • Owners of previous Sonnox licence Generations (G4 or earlier) will need to upgrade to G5 before being eligible for this upgrade.
  • SoundGrid is not currently compatible with the entire Oxford range - for more information about which plug-ins you can upgrade, please read What is Waves SoundGrid?

We're always happy to help! If you have any further questions, please contact create a support ticket.